GCP Outage

Incident Report for Rise Works

Resolved

System is back online following our tests and updates from Google at https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW.
Posted Jun 12, 2025 - 22:05 UTC

Monitoring

GCP Infrastructure is starting to work again. Continuing to test and monitor Google updates. https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 20:31 UTC

Identified

We are continually monitoring GCP incident status and will open services again when Google Cloud is stable. More details can be found here. https://status.cloud.google.com/index.html
Posted Jun 12, 2025 - 19:50 UTC

Investigating

Google Cloud services are unresponsive. Investigating impact and ETR.
Posted Jun 12, 2025 - 18:38 UTC
This incident affected: Pay Remittance, Deposits, Pay API, Google Cloud Platform Google Container Engine, and Onboarding.