Page Not Found

Incident Report for Rise Works

Postmortem

There was a change to our website causing traffic to not route to the correct page. This only effected public website users and not users in RisePay.

Posted Oct 30, 2024 - 17:43 UTC

Resolved

Reports that some European users were receiving Page Not Found errors.
Posted Oct 30, 2024 - 09:30 UTC