Intermittent blockchain transaction failures

Incident Report for Rise Works

Postmortem

One of the blockchain nodes was being overwhelmed and causing delays in execution and ultimately failures of the request due to processing time. The node has been replaced with a more performant system.

Posted Apr 29, 2025 - 17:51 UTC

Resolved

Some HTTP requests are returning failures when attempting to execute a payment or withdrawal.
Posted Apr 29, 2025 - 15:00 UTC