Blockchain congestion causing transactions to fail

Incident Report for Rise Works

Resolved

This incident has been resolved.
Posted Jun 20, 2024 - 15:08 UTC

Monitoring

Blockchain transactions are stabilized and starting to finalize.
Posted Jun 20, 2024 - 14:49 UTC

Investigating

Arbitrum's cost of transaction inclusion is erratic and causing some transactions to fail. It's anticipated to normalize soon.
Posted Jun 20, 2024 - 12:34 UTC
This incident affected: Pay Remittance, Pay API, Infura Arbitrum Mainnet, and Onboarding.