Login Failures

Incident Report for Rise Works

Resolved

Vendor has resolved system issues.
Posted Feb 06, 2025 - 22:26 UTC

Investigating

Rise's authentication vendor is currently experiencing issues causing logins to be slow or to fail. We're working with the vendor to get the system working again. Time to repair is unknown.
Posted Feb 06, 2025 - 22:00 UTC
This incident affected: Pay Remittance, Deposits, and Onboarding.