System degradation

Incident Report for Rise Works

Resolved

Performance issues resolved by increasing capacity. All system operating normally.
Posted Jan 27, 2026 - 14:45 UTC

Monitoring

A fix has been implemented and we're continuing to monitor the situation.
Posted Jan 27, 2026 - 13:49 UTC

Investigating

There is an ongoing performance issue Rise's cloud infrastructure. Investigation is underway.
Posted Jan 27, 2026 - 13:31 UTC
This incident affected: Pay Remittance, Pay API, Google Cloud Platform Google Container Engine, and Onboarding.