Ongoing issue with authentication provider

Incident Report for Rise Works

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 16:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 15, 2025 - 16:22 UTC

Monitoring

Some requests to log-in to Rise are failing due to a third party. We're monitoring the status and will update you as the incident progresses.
Posted Sep 15, 2025 - 14:06 UTC
This incident affected: Pay Remittance, Deposits, Pay API, and Onboarding.