Blockchain Congestion

Incident Report for Rise Works

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 23:56 UTC

Investigating

Some transactions are not processing due to ongoing blockchain congestion. We're actively monitoring the situation and transaction will process as normal as soon as congestion subsides.
Posted Oct 10, 2025 - 21:45 UTC
This incident affected: Deposits, Pay API, Infura Arbitrum Mainnet, and Onboarding.