Withdrawals Halted

Incident Report for Rise Works

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 21:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 22, 2026 - 20:30 UTC

Identified

Ongoing issue with withdrawals, we're halting all until a resolution has bee provided.
Posted Jun 22, 2026 - 15:53 UTC
This incident affected: Pay Remittance and Deposits.